HP ProLiant DL360 G7 Video Driver

I was looking for a video driver for the HP ProLiant DL360 G7 so I could import it into ConfigMgr for the purposes of deploying Windows Server 2008 R2 to them. Oddly enough, HP doesn’t list a video driver available for download on the driver download page for this system …

Continue reading

ConfigMgr 2007: PXE Service Point Installation Error

Just recently, I was getting an error in the pxemsi.log (pxemsi.log.lasterror) while trying to install a ConfigMgr 2007 PXE Service Point (PSP): DEBUG: Error 2203:  Database: C:WindowsInstaller1e0d86.ipi. Cannot open database file. System error –2147287037 MSI (s) (20:FC) [09:46:12:689]: Product: SMS PXE Service Point — Internal Error 2203. C:WindowsInstaller1e0d86.ipi, –2147287037 Internal …

Continue reading

PowerShell: Update your ConfigMgr OSD Boot Images to WinPE 3.1

When you upgrade your boot images in Microsoft’s System Center Configuration Manager (SCCM / ConfigMgr) 2007 from WinPE 3.0 to WinPE 3.1, you must run the ExportDefaultBootImage() WMI method on the SMS_BootImagePackage WMI class for each boot image architecture. Typically this would simply include x86 (32-bit) and x64 (64-bit) boot …

Continue reading

ConfigMgr 2012 Beta 2: Setting the Network Access Account

You might need to set the Network Access Account (NAA) in System Center Configuration Manager 2012 Beta 2 if you are deploying operating systems with it. Windows Pre-Execution (WinPE) needs an account to access content on the distribution point. In order to set the network access account, open the SCCM …

Continue reading

ConfigMgr 2012 Beta 2: PXE Booting for OSD

I recently was trying to PXE bootstrap an operating system deployment (OSD) job from a ConfigMgr 2012 Beta 2 PXE server, and was getting this message in the smspxe.log on the SCCM primary site server: PXE::CBootImageManager::FindMatchingArchitectureBootImage Warning: Matching Processor Architetcure Boot Image (0) not found

Continue reading

Silently Installing the Windows 7 AIK

So I’m working on some automated lab build “stuff” and I tried to silently install the Windows 7 AIK using a simple call to msiexec. Apparently there is something built into the Windows 7 AIK MSI package that prevents it from being installed non-interactively. This is a bit frustrating. Upon …

Continue reading