WinPE 3.0 Storage Driver Issues

I was using the 8.9.2.1002 iaAHCI driver (dated 08/07/2009) from Intel in WinPE 3.0, on a Lenovo T60 (and other models), and when I tried to browse the fixed disk (c:), I get this message: “The volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that … Read moreWinPE 3.0 Storage Driver Issues

PowerShell: AD Workstation Cleanup Script version 2.0

Update (2010-08-25): I have posted a newer version of this script. A little while ago, I posted a PowerShell script that detects old machine accounts in Active Directory, and disables or deletes them, based on certain ages (in days). I’ve continued work on this script, such that it now logs information to Excel about actions … Read morePowerShell: AD Workstation Cleanup Script version 2.0

Troubleshooting Failed Software Updates in ConfigMgr

Hello, I just wanted to take a few moments to share the thought process that I use to troubleshoot failing software updates in Configuration Manager. On several occasions for me, this has been the most straightforward method of figuring out why an update is failing, and determining how to resolve the issue. How to Manually … Read moreTroubleshooting Failed Software Updates in ConfigMgr

MDT 2010 Driver Injection Slowness

After upgrading from MDT 2008 to 2010, I recently experienced an issue with MDT / WinPE 3.0 that was simply a driver issue. The initial symptom reported to me was: Driver detection / copying (ZTIDrivers.wsf) is taking a long time in WinPE on a Lenovo T60. The build completed, but hung on the driver injection … Read moreMDT 2010 Driver Injection Slowness

Deployment Workbench: Windows Imaging Error

I just installed the Windows AIK for Windows7, and MDT 2010 on my 64-bit Windows 7 Release Candidate system, and attempted to open the Deployment Workbench. It opened just fine, but when I selected the Deployment Shares node in the snap-in, I got this error: “The file C:Windowssystem32wimgapi.dll(version 6.1.7100.0 (winmain_win7rc.090421-1700)) is older than the installed Windows … Read moreDeployment Workbench: Windows Imaging Error

MDT 2008 to 2010 Upgrade Successful!

Yesterday, I upgraded MDT from 2008 to 2010. The high-level steps I followed to upgrade it were as follows: Uninstall Windows AIK 1.1 Uninstall MDT 2008 Install Windows 7 / 2008 R2 AIK Install MDT 2010 Open MDT 2010 console and upgrade deployment shares Test task sequence on virtual machine Please note: The Microsoft .NET Framework … Read moreMDT 2008 to 2010 Upgrade Successful!

GemBox’s Excel .NET Library

If you’re at all familiar with the Excel APIs, you’ll know that they’re often quite frustrating to work with. The fact that the Office 2007 .NET API is simply a wrapper around the COM interface doesn’t make it very appealing either. I e-mailed my dad, who develops software, and he sent me a link to … Read moreGemBox’s Excel .NET Library

Failing software updates in SCCM / WSUS

I recently was troubleshooting an issue with some failing software update installations being deployed via SCCM / WSUS, and finally found out what was affecting them. All of the failed updates were related to Microsoft Office, so that kind of tells you something right there. It turns out, the root cause of the installation failure was … Read moreFailing software updates in SCCM / WSUS

SCCM – Changing Client Cache Location

Update (2009-10-05 12:30 PM): Thanks to Todd Hemsell, I now know that you have to restart the ccmexec service in order for the change to take effect. I’ve updated the scripts appropriately. — So you’ve got System Center Configuration Manager (SCCM) 2007 in place, and for whatever reason, you’re looking to change the location of … Read moreSCCM – Changing Client Cache Location